Back to overview
Downtime
Extended downtime
May 13, 2026 at 6:32pm UTC
Affected services
randomdebugguy.freeddns.org
Updated
May 18, 2026 at 2:21am UTC
We are not able to bring these services back up.
Affected services
Created
May 13, 2026 at 6:32pm UTC
ISP has changed our IP address unexpectedly, we are contacting them now but have no idea as to when this will be resolved.
Affected services