Back to overview
Downtime
Downtime
Feb 25, 2026 at 2:12am UTC
Affected services
randomdebugguy.freeddns.org
Resolved
Feb 25, 2026 at 5:36am UTC
All services have been brought back online.
Affected services
Updated
Feb 25, 2026 at 5:23am UTC
Power has been restored to the hosts. We are monitoring for stability/service availability.
Affected services
Created
Feb 25, 2026 at 2:12am UTC
Power outage occurred at the service provider, we have no ETA as this issue is out of our control.
Affected services